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Penelitian ini bertujuan untuk merancang sebuah robot yang dapat 

mendeteksi keberadaan logam yang mengirimkan lokasi melalui aplikasi 

telegram. Manfaat penelitian ini adalah merancang sebuah robot untuk 

mendeteksi logam yang dingunakan untuk mencari lokasi sebuah 

kecelakaan pesawat untuk kemudian mengirim koordinat lokasi dengan 

menggunakan medul gps melalui aplikasi telegram. Metode penelitian 

yang digunakan dalam pembuatan robot ini ini adalah metode prototype, 

dimana tahapan penelitiannya berupa analisis kebutuhan, perancangan 

prototype, evaluasi prototyping, coding system, menguji system, evaluasi 

system dan menggunakan system. Dari hasil penelitian tersebut telah 

berhasil menciptakan sebuah robot yang bergerak secara otomatis untuk 

mendeteksi logam dan mengirimkian koordinat lokasi penemuan logam 

melalui aplikasi telegram. 

  
  

Pendahuluan  

Pada era digital sekarang ini perkembangan teknologi khususnya teknologi 

mikrokontroler dan internet berkembang sangat pesat. Perkembangan tersebut telah 

memasuki ke dalam sendi-sendi kehidupan manusia. Peralatan yang tadinya digunakan 

secara manual kini banyak yang berubah menggunakan teknologi kendali seperti kecerdasan 

buatan (Artificial Intelegent), fuzzy logic bahkan internet of things (IOT). 

Kecelakaan pesawat merupakan kejadian luar biasa selain menyangkut nyawa 

penumpang, kecelakaan pesawat juga harus diteliti dengan benar faktor penyebab kecelakaan 

pesawat tersebut sebagai bahan pertimbangan untuk studi kelayakan dari sebuah pesawat dan 

peningkatan kualitas sumber daya manusia (SDM) yang bekerja pada sebuah maskapai 

penerbangan. 

Dibutuhkan peralatan khusus untuk mencari titik lokasi jatuhnya pesawat. Peralatan 

khusus ini didesain untuk dapat mendeteksi keberadaan logam yaitu serpihan dari badan 

pesawat dan blackbox, melewati medan di pegunungan dengan kondisi tanah yang beragam 

teksturnya seperti rawa dan tanah bergelombang serta mampu mengirimkan koordinat lokasi 

pada saat logam dari badan pesawat ditemukan. 
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Berdasarkan latar belakang di atas, penulis bermaksud membuat suatu robot yang 

berfungsi mencari lokasi kecelakaan peesawat dengan mendeteksi logam, robot dapat berjalan 

menyusuri medan yang sulit karena menggunakan roda tank dan dapat mengirimkan 

koordinat lokasi kecelakaan melalui aplikasi telegram.     

Fuzzy Logic adalah pendekatan komputasi berdasarkan derajat kebenaran daripada 

logika "benar atau salah" atau “1 atau 0” yang menjadi dasar komputer modern. Ide logika 

fuzzy pertama kali dikemukakan oleh Lotfi Zadeh dari University of California di Berkeley 

pada tahun 1960an. 

Sistem fuzzy pertama kali diperkenalkan oleh Prof. L. A. Zadeh dari Barkelay pada tahun 

1965. Sistem fuzzy merupakan penduga numerik yang terstruktur dan dinamis. Sistem ini 

mempunyai kemampuan untuk mengembangkan sistem intelijen dalam lingkungan yang tak 

pasti. Sistem ini menduga suatu fungsi dengan logika fuzzy. Dalam logika fuzzy terdapat 

beberapa proses yaitu penentuan himpunan fuzzy, penerapan aturan IF-THEN dan proses 

inferensi fuzzy.  (Salman, 2017)   

 

Metode   

Metode yang digunakan penulis dalam pengumpulan data adalah sebagai 

berikut :  

  a. Observasi 

Dalam perancangan ini peneliti melakukan pengamatan langsung terhadap 

kegiatan BPBD kabupaten Tangerang dalam menangani bencana, khususnya dalam 

pencarian titik lokasi kecelakaan pesawat. 

b. Wawancara 

Mengadakan wawancara dengan bagian lapangan dari pihak BPBD kabupaten 

Tangerang mengenai proses pencarian titik lokasi kecelakaan yang terjadi di daerah 

pegunungan atau daerah yang sulit dijangkau. 

c  Studi Pustaka  

Dalam pengumpulan data penulis mengumpulkan data dan informasi melalui studi 

pustaka atau referensi yang bersifat teori dan pengetahuan yang berhubungan 

dengan proposal skripsi ini yang membahas tentang perancangan robot pendeteksi 

logam (metal detector) dan sistem untuk membaca koordinat lokasi menggunakan 

modul gps, yang diperoleh dengan cara mempelajari jurnal-jurnal penelitian atau 

skripsi, internet dan buku yang dijadikan bahan referensi untuk acuan dalam 

penelitian ini. 

  

Metode penelitian pengembangan sistem yang digunakan dalam menyelesaikan 

penelitian ini mengunakan model Rapid Appliction Development yang terdiri atas :  

1. Analisis Kebutuhan 

Pada tahapan peneliti melakukan analisis kebutuhan dari alat yang akan dibuat. 

Dengan menginventarisir alat dan bahan yang dibutuhkan. 

2. Merancang prototype / prototyping 

Merancang prototyping merupakan bentuk sementara dari sistem atau alat, untuk 

kemudian dapat dianalisis kerja dan alur sistemnya sesuai dengan tujuan atau tidak. 

3. Evaluasi Prototyping 

Tahap ini merupakan hasil dari analisi prototype untuk kemudian dapat di evaluasi 

kekurangan yang terdapat pada sistem untuk perbaikan kerja dan alur sistem. Hasil 

dari evaluasi digunakan untuk perancangan prototipe selanjutnya. 
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4. Coding Sistem 

Tahap Coding ini merupakan penterjemahan dari prototype dalam bentuk program 

yang dibuat dengan bahasa pemrograman agar sistem berjalan sesuai dengan 

tujuan yang ditentukan di awal. 

5.  Menguji Sistem 

Tahap selanjutnya adalah menguji sistem untuk mengetahui sejauh mana sistem 

berjalan sesuai dengan tujuan awal. Pengujian sistem ini dapat dilakuan dengan 

metode Blackbox  

6.  Evaluasi Sistem 

Tahapan ini adalah mengevaluasi hasil dari pengujian sistem. Untuk mengetahui 

apakah sistem berjalan sesuai dengan yang diharapakan.  Pada tahap jika hasil 

evaluasi belum sesuai maka akan kembali lagi ke tahapan coding sistem untuk 

meperbaiki sistem. 

7.  Menggunakan Sistem 

Tahapan akhir dari pembuatan sistem yaitu menggunakan sistem yang dibuat. 

 

Perancangan  

 Perancangan dilakukan untuk memmbuat robot dalam mendeteksi titik lokasi kecelakaan. 

Perancangan dapat digambarkan sebagai berikut :  

1. Perancangan Rangkaian Modul Metal Detector 

Penulis menggunakan modul metal detector yang dipasang pada bagian depan 

bawah dari robot untuk mendeteksi keberadaan logam. Modul Metal Detector dapat 

dihubungkan ke wemos pada pin 5v sebagai sumber daya, pin GND sebagai ground, 

dan pin A0 sebagai pin untuk menerima sinyal dari modul metal detector ini. 

Tabel 3. 1 Pengkabelan (wiring) WemosD1ESP8266 – Metal Detector 

Wemos D1 ESP8266 Modul Metal 

Detector 

5 V VCC 

GND GND 

A0 Data 
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Gambar 3. 1 Rangkaian Wemos dengan Modul Metal Detector 

 

2. Perancangan Rangkaian Ultrasonik 

Pada penelitian ini penulis menggunakan sensor ultrasonik sebagai komponen 

input (sensor) yang berfungsi untuk mendeteksi keberadaan benda di depan robot 

sehingga robot dapat menghindar dan tidak menabrak benda di depannya dan 

dalam penelitian ini penulis menggunakan 3 sensor ultrasonik masing-masing 

sensor ultrasonik diletakkan di kanan, kiri dan tengah robot. 

                   Tabel 3. 2 Pengkabelan antara Wemos D1 ESP8266 dengan Sensor Ultrasonik 

 

Wemos D1 ESP8266 

Sensor Ultrasonik  

Kiri Tengah Kanan 

VCC VCC VCC VCC 

GND GND GND GND 

D1 echo - - 

D2 trigger - - 

D10 - echo - 

D11 - trigger - 

D12 - - echo 

D13 -  trigger 

 

 

 

Gambar 3. 2 Rangkaian Wemos D1 ESP8266 dengan sensor Ultrasonik 
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3. Perancangan  Rangkaian Modul GPS  

Modul GPS GY-NEO6MV2 berfungsi sebagai penerima GPS (Global Positioning 

System Receiver) yang dapat mendeteksi lokasi dengan menangkap dan 

memroses sinyal dari satelit navigasi. 

Modul GPS ini memiliki 4 pin yaitu pin VCC, GND, TX dan RX 

Tabel 3. 3 Pin Out GPS GY-NEO6MV2 

PIN Fungsi 

GND Ground dari Arduino or power supply 

TX digunakan untuk komunikasi serial 

RX digunakan untuk komunikasi serial 

VCC 
5Vdc dari power supply eksternal atau 

arduino 

 

 

Gambar 3. 3 Rangkaian Modul GPS GY-NEO6MV2 

4. Rangkaian Keseluruhan 

Pada gambar merupakan rangkaian hardware secara keseluruhan dari 

Robot Pendeteksi Logam dan Evakuasi Bencana. Komponen yang digunakan 

adalah Wemos D1, Sensor Metal Detector, Modul GY-NEO6MV2, dan Motor 

Driver L298N. 
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Gambar 3. 4 Rangkaian Keseluruhan Robot Evakuasi Kecelakaan Pesawat 

5. Diagram Blok 

Pada blok diagram dapat dibagi menjadi tiga bagian yaitu input, proses, dan 

output. Pada bagian input terdapat 2 buah komponen yaitu sensor metal 

detector  yang berfungsi untuk mendeteksi keberadaan logam yang 

kemudian data sensor tersebut dikirim Wemos D1 ESP8266 untuk mulai 

diproses. 

 

 

Gambar 3. 5 Blok Diagram Robot Pencari Titik Lokasi Kecelakaan Pesawat 

 

Hasil dan Pembahasan  
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1. Pembahasan Rangkaian 

Komponen yang digunakan pada robot pencari lokasi titik kecelakaan pesawat 

terdiri dari  Wemos D1 ESP8266, Sensor Metal Detector, sensor ultrasonik, 

Buzzer, Modul GY-NEO6MV2, dan Motor Driver L298N. 

Wemos D1 berfungsi sebagai alat untuk memproses input dan output dari 

masing – masing komponen pendukung. Komponen – komponen tersebut 

mendapat sumber daya dari pin 5V pada Wemos D1. Wemos D1 sendiri bisa 

mendapatkan arus listrik dari adaptor 12V atau 9V. 

 

 

 

Gambar 4. 1 Pembahasan Rangkaian 

2. Implementasi 

Berdasarkan dengan hasil perancangan diatas maka telah tercipta robot pencari 

titik lokasi kecelakaan pesawat yang dilengkapi dengan sensor metal detector 

dan penerima sinyal gps untuk menentukan lokasi kecelakaan. Robot 

menggunakan mekanik pengerak roda tank agar mempermudah mobilisasi dari 

robot ini. 

 

 

Gambar 4. 2 Robot Pencari Titik Lokasi Kecelakaan Pesawat 
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Gambar 4. 3 Robot Pencari Titik Lokasi Kecelakaan Pesawat 

3. Perancangan Perangkat Lunak  

 Perancangan pemrograman perangkat lunak ini menggunakan software IDE 

Arduino 1.8.8 yang diperoleh dengan mengunduhnya di alamat 

http://arduino.cc. Arduino IDE pada dasarnya belum bisa mengenali board 

dengan chip ESP8266, maka dari itu perlu menambahkan board ESP8266 ke 

Arduino IDE. Untuk lebih jelasnya, mari ikuti langkah-langkah berikut ini. 

1. Dibuka program Arduino IDE kemudian dipilih menu File > Preference seperti 

pada gambar 4.4 di bawah ini : 

 

Gambar 4. 4 Menu IDE Arduino untuk menambahkan board Wemos 

D1 ESP8266 

2. Pada bagian Additional Boards Manager URLs  diisikan alamat : 

http://arduino.esp8266.com/stable/package_esp8266com_index.json 

kemudian diklik OK seperti pada gambar 4.12 di bawah ini : 

 

                             

Gambar 4. 5 Memasukkan URLs Additional Board 
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3. Dibuka menu Tools > Board: > Boards Manager, ditunggu sampai program 

memuat daftar board lalu diketik “ESP8266” pada kolom search, pastikan 

Internet dalam keadaan aktif Pilih esp8266 by ESP8266 Community lalu diklik 

Install seperti pada gambar 4.13 dibawah ini : 

                       

Gambar 4. 6 Install esp8266 by ESP8266 Commnunity 

Setelah selesai akan muncul daftar board baru pada menu Tools > Board seperti 

pada gambar 3.14 dibawah ini: 

 

                           

                                Gambar 4. 7 Board Wemos D1 R2 di IDE arduino 

Langkah-langkah meng-upload program dari IDE arduino ke board Wemos D1 

ESP8266 pada saat program telah selesai agar board Wemos D1 ESP8266 

dapat berfungsi sesuai perintah-perintah yang dibuat di software IDE arduini. 

Berikut tahap proses upload program software ke board arduino Wemos D1 

ESP8266 :  

1. Dihubungkan Kabel Micro USB pada board Wemos D1 ESP8266  ke 

computer/laptop yang sudah diinstall software IDE Arduino, Jika sudah 

terhubung lampu LED PWR akan menyala.  

2.  Diinstall Software IDE 1.8.8 sketch arduino dengan meng-unduh melalui 

alamat http://arduino.cc, dibuka file installer dan ikuti tahapan instalasi 

sampai selesai. apabila telah diinstal shortcurt IDE 1.8.8 akan muncul di desktop 

computer/laptop.  
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3. Dibuka software IDE Arduini dengan meng-double klick shortcurt IDE 1.8.8 

untuk memulai membuat program dan dilakukan pengisian program yang 

diinginkan maka tampilannya dapat dilihat pada gambar 4.16. di bawah ini : 

 
Gambar 4. 8 Tampilan Awal Software Arduino IDE 1.8.8 

 

Langkah selanjutnya yang perlu dilakukan adalah memilih tipe board 

mikrokontroler yang akan digunakan pada perancangangan ini digunakan board 

Wemos D1 ESP8166 pada software arduino IDE, caranya adalah dengan meng-

klick menu tools – board – Wemos D1 R1, seperti ditunjukkan pada gambar 

4.17. berikut : 

 

 

Gambar 4. 9 . Memilih Tipe Mikrokontroler dengan menu tools 

 

Setelah memilih board Setelah memilih board arduino yang akan digunakan 

yaitu Wemos D1 R1, langkah selanjutnya adalah memasukkan program dari 

sistem yang akan dibuat untuk Robot Pencari Titik Lokasi Kecelakaan Pesawat 

dengan menggunakan software arduino IDE seperti pada gambar 4.18. berikut: 
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Gambar 4. 10 Tampilan Program Robot Pencari Titik Lokasi 

Kecelakaan Pesawat 

Setelah pembuatan program selesai langkah terakhir adalah meng-upload 

program ke dalam board Wemos D1 R1 ESP8266 dengan cara diklick Menu 

Sketch – Klick Upload, lalu ditunggu proses upload sampai selesai. g. Untuk 

lebih jelasnya dapat dilihat pada gambar 4.19 proses upload dan upload telah 

selesai di bawah ini 

                          

Gambar 4. 11 Proses Upload dan Upload telah Selesai 

Membuat Program Notifikasi ke Telegram 

Membuat Bot Telegram dengan Botfather 

1. Buka Applikasi Telegram, lalu cari BotFather. 

2. Kemudian buka BotFather 

3. Klik START, Lalu ketik /newbot 

4. selanjutnya akan diminta memberikan nama bot dan username bot.  

5. Jika sudah berhasil membuat nama bot makan akan muncul Token. 

     Token ini yang nanti nya digunakan sebagai alamat telegram kita. 

Pengujiian Komponen 

Pengujian ini dilakukan pada setiap komponen dan modul yang digunakan oleh 

Pencari Titik Lokasi Kecelakan ini. Hal ini dilakukan untuk mengtahui apakah 

masing-masing komponen dan modul bekerja dengan baik sesuai fungsinya. 

Tabel 4. 1 Hasil Pengujian Komponen 

No Komponen Tegangan 

Input 

Hasil 

1. Wemos D1 

ESP8266 

9-12V Berfungsi 
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2. Sensor 

Metal 

Detectro 

3.3.V Berfungsi 

3. Buzzer 5V Berfungsi 

4. Motor 

Driver 

L298N 

5V Berfungsi 

5. Modul GPS 

GY-

NEO6MV2 

5 V Berfungsi 

 

Pengujian Program Kirim Telegram ke Bot Telegram 

Pengujian ini bertujuan untuk memastikan pesan telegram yang dikirim melalui 

board Wemos D1 ESP8266 berhasil terkirim ke bot telegram. Pengujian ini 

dilakukan dengan memprogram board Wemos D1 ESP8266 dengan program 

kirim telegram sebagai berikut : 

  

                       

Gambar 4. 12 Hasil Pengujian Buzzer 

Kemudian program di atas di upload ke board Wemos D1 ESP8266, 

pengujian dilakukan dengan melihat tampilan serial monitor dari Ardui IDE, 

beriku tampilan serial monitor dari program kirim telegram : 
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                          Gambar 4. 13 Tampilan Serial Monitor Program Kirim 

Telegram 

Kemudian pengujian juga dilakukan dengan melihat aplikasi 

telegram, berikut tampilan bot telegram menerima pesan dari Wemos D1 

ESP8266 : 

          .  

Gambar 4. 14 Bot Telegram Menerima Pesan dari Wemos ESP8266 

Kesimpulan   

Berdasarkan hasil percobaan, dapat ditarik kesimpulan bahwa sensor metal detector 

dapat digunakan untuk mencari keberadaan benda yang mengandung unsur logam dan modul 

gps serta dapat memberikan informasi posisi suatu benda atau alat dengan bantuan satelite. 
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